Perl and CGI

 
Forums: » Register « |  User CP |  Games |  Calendar |  Members |  FAQs |  Sitemap |  Support | 
User Name:
Password:
Remember me



Go Back   Tutorialized ForumsWeb Design & DevelopmentPerl and CGI

Reply
Add This Thread To:
  Del.icio.us   Digg   Google   Spurl   Blink   Furl   Simpy   Y! MyWeb 
Thread Tools Search this Thread Rate Thread Display Modes
 
Unread Tutorialized Forums Sponsor:
  #1  
Old September 19th, 2008, 08:30 AM
mykkah mykkah is offline
Registered User
Tutorialized Newbie (0 - 499 posts)
 
Join Date: Sep 2008
Posts: 1 mykkah User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 23 m 4 sec
Reputation Power: 0
Exclamation Internal Server Error???

Ok, So I bought a template from a web template site thinking that everything I needed would be provided, but I was waaaaay off! I got every thing setup and running except the Mail Form. I really am not all that savvy on coding and I'm more of a designer... this is why I have no clue what's going on. I've spent about 15 hours trying to figure out whats wrong but I can't for the life of me???

I punched in what I thought was all I needed in the actual code on the "contacts Page" but it's still not working? below is the Mail Form code(in Red) from the page. Does this look like it should function if it was directed to the "MailForm.pl" file correctly?

And I keep hearing about a redirect after the submit buttons pushed? does it look like this is in this code (in red)?

after I hit submit this is what I get "Internal Server Error, The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator,(e mail address) and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log."


<form id="form" action="web address/cgi-bin/FormMail.pl" enctype="multipart/form-data">
<div class="line"><input type="text" value="name:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="title:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="company name:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="address:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="address cont'd:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="city:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="state:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="e-mail:" onfocus="this.value=''" /></div>
<div class="line"><input type="text" value="phone:" onfocus="this.value=''" /></div>
<div>
<textarea cols="30" rows="40" onfocus="this.value=''">message:</textarea><br />
<a href="#" class="link_3" onclick="getElementById('form').submit()">send</a> <a href="#" class="link_3" onclick="getElementById('form').reset()">clear</a>
</div>
</form>


This is what my FormMail.pl looks like (in gray).

# USER CONFIGURATION SECTION
# --------------------------
# Modify these to your own settings. You might have to
# contact your system administrator if you do not run
# your own web server. If the purpose of these
# parameters seems unclear, please see the README file.
#
BEGIN
{
$DEBUGGING = 1;
$emulate_matts_code= 0;
$secure = 1;
$allow_empty_ref = 1;
$max_recipients = 5;
$mailprog = '/usr/lib/sendmail -oi -t';
$postmaster = 'info @ mysite . com';
@referers = qw(mysite . com);
@allow_mail_to = qw(info @ mysite . com);
@recipients = qw(info @ mysite . com);
%recipient_alias = ();
@valid_ENV = qw(REMOTE_HOST REMOTE_ADDR REMOTE_USER HTTP_USER_AGENT);
$locale = '';
$charset = 'iso-8859-1';
$date_fmt = '%A, %B %d, %Y at %H:%M:%S';
$style = '/css/nms.css';
$no_content = 0;
$double_spacing = 1;
$wrap_text = 0;
$wrap_style = 1;
$send_confirmation_mail = 0;
$confirmation_text = <<'END_OF_CONFIRMATION';
Fromyou @ your . com)
Subject: form submission

Thank you for your form submission.

END_OF_CONFIRMATION


if anyone can help I would really really appreciate it! I'm getting reamed out because the mail page doesn't work and I have no clue where to even start???

Thanks for any and all help!

Reply With Quote
Reply

Viewing: Tutorialized ForumsWeb Design & DevelopmentPerl and CGI > Internal Server Error???


Developer Shed Advertisers and Affiliates


Thread Tools  Search this Thread 
Search this Thread:

Advanced Search
Display Modes  Rate This Thread 
Rate This Thread:


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
View Your Warnings | New Posts | Latest News | Latest Threads | Shoutbox
Forum Jump


Forums: » Register « |  User CP |  Games |  Calendar |  Members |  FAQs |  Sitemap |  Support | 
  
 

Powered by: vBulletin Version 3.0.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

© 2003-2018 by Developer Shed. All rights reserved. DS Cluster - Follow our Sitemap